VLAN Trunk Between Cisco and HP Procurve switch

By | June 5, 2014

VLAN Trunk Between Cisco and HP Procurve switch

In this example we are going to see how we can use Cisco and HP switches together for Vlan trunking. Before we get into details, let me describe the difference in ‘terms‘ using both in Cisco and HP.

Description                                                                                        Cisco                    ProCurve
A port that belongs to a unique VLAN                                     Access mode            Untagged
A port carries multiple VLANs using 802.1q tags               Trunk mode              Tagged

Now to our example, here we are going to create two VLANs, VLAN 100 (Data) and VLAN 200 (Data2) and make use of these vlans are setup on both Cisco and HP switches.

In this example we are going to use the 48th port on both HP and Cisco as the trunk ports and interconnects togther on these ports.

On Procurve Switch:
Go to configuration mode and enter the following commands,

Procurve(config)#vlan 100
Procurve(config)#name “Data”
Procurve(config)#tagged 48

Procurve(config)#vlan 200
Procurve(config)#name “Voice”
Procurve(config)#tagged 48

You can see the configuration as

Procurve(config)#sh run

vlan 100
name “Data”
tagged 48
exit

vlan 200
name “Data2”
tagged 48
exit

On Cisco Switch:

Go to configuration mode and enter the following commands,

Cisco>enable
Password:
Cisco#conf t
Cisco(config)#vlan 100
Cisco(config-vlan)#name “Data”

Cisco(config-vlan)#vlan 200
Cisco(config-vlan)#name “Data2”

Cisco(config-vlan)#exit
Cisco(config)#interface gi1/0/48
Cisco(config-if)#description “Uplink to Procurve switch”

Cisco(config-if)#switchport trunk encapsulation dot1q
Cisco(config-if)#switchport trunk allowed vlan 100,200
Cisco(config-if)#switchport mode trunk

“show run” on enable mode will list all the configuration and the switch port configuration will be like as follows,

interface GigabitEthernet1/0/48
description “Uplink to Procurve switch”
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 100-200
switchport mode trunk

I hope this helps!!!

4 thoughts on “VLAN Trunk Between Cisco and HP Procurve switch

  1. Yan Linn

    what about for HP configuration for trunk “Downlink to Cisco Switch” . Thanks

    Reply
  2. Steve

    If you were to add an untagged management vlan “vlan 1000” to port 48 the HP switch and add an IP to it how would you configure the Cisco switch correspondingly so the HP switch could me managed from a workstation connected to the Cisco? This works between HP switches but I seem to have something missing to do the same between a Cisco and an HP.

    Reply
    1. james Post author

      CISCO would require a native VLAN to be set. Native VLAN is like an untag VLAN on a trunk port.

      Reply

Leave a Reply